# R3
hostname R3
int l0
ip add 150.1.3.3 255.255.255.255
!
int g1.34
encap dot 34
ip add 155.1.34.3 255.255.255.0
int g1.13
encap dot 13
ip add 155.1.13.3 255.255.255.0
!
router eigrp 100
network 0.0.0.0
!
router bgp 100
bgp router-id 150.1.3.3
bgp log-neighbor-changes
network 150.1.3.3 mask 255.255.255.255
neighbor 150.1.2.2 remote-as 100
neighbor 150.1.2.2 update-source Loopback0
# R4
hostname R4
int l0
ip add 150.1.4.4 255.255.255.255
!
int g1.34
encap dot 34
ip add 155.1.34.4 255.255.255.0
int g1.24
encap dot 24
ip add 155.1.24.4 255.255.255.0
!
router eigrp 100
network 0.0.0.0
!
router bgp 100
bgp router-id 150.1.4.4
network 150.1.4.4 mask 255.255.255.255
neighbor 150.1.1.1 remote-as 100
neighbor 150.1.1.1 update-source Loopback0
# R10
hostname R5
int l0
ip add 150.1.10.10 255.255.255.255
!
int g1.101
encap dot 101
ip add 155.1.101.10 255.255.255.0
int g1.102
encap dot 102
ip add 155.1.102.10 255.255.255.0
!
router bgp 10
bgp router-id 150.1.10.10
bgp log-neighbor-changes
network 150.1.10.10 mask 255.255.255.255
neighbor 155.1.101.1 remote-as 100
neighbor 155.1.102.2 remote-as 100
Solution
1) Explain why it is happening
R1 and R2 are the route reflectors, and both routers are going to choose the directly connected External route as the "best path". They pass this information on to routers 4 and 3, respectively. Now each of these routers sees the best path as being through their own Route reflector, but they must forward to each other to get there. This causes the packets to "bounce back and forth" forever.
2) Fix it (no tunnels/static routes)
On all interfaces facing other routers in AS 100: "mpls ip"
That's it!
3) Explain your fix
After MPLS has been enabled, R3 and R4 will use the labels to label-switch to the next hop instead of looking up the destination in their respective RIBs. This causes a tunnel-like effect, since R3 and R4 will only look at the labels as the packet passes through them.
No comments:
Post a Comment